appleseed Users Forum

Appcrash on Windows 7


#1

I recently downloaded appleseed to try it out. It crashes whenever I attempt to render anything. There isn’t much on the web relating to this. The program looks incredible, would love to try it out.

I get this message every time, whether it be the Cornell box test scene or the heightmaps plugin.


#2

The 1.2.0-beta release was–incorrectly–compiled with SSE 4.2 support (we actually only use SSE 4.1 instructions right now). Maybe your CPU doesn’t support them.

I just updated the 1.2.0-beta release:

Now, the default Windows build relies on SSE 2 instructions only (which virtually all modern CPUs support):
https://github.com/appleseedhq/appleseed/releases/download/1.2.0-beta/appleseed-1.2.0-beta-0-g7cc9ec1-win64-vs120.zip

The SSE 4.2 build is still available:
https://github.com/appleseedhq/appleseed/releases/download/1.2.0-beta/appleseed-1.2.0-beta-0-g7cc9ec1-win64-vs120-sse42.zip

Hope this helps.


#3

Thank you, I ended up downloading the earlier version just this morning, it works.


#4

having the same problem and tried everything i could


#5

@ablubeti What operating system are you on, and what is your CPU?


#6

windows 7 and i3 processor cpu


#7

This is curious, you CPU seems to support all instruction sets we rely one.

Did you already try this version? https://github.com/appleseedhq/appleseed/releases/download/1.2.0-beta/appleseed-1.2.0-beta-0-g7cc9ec1-win64-vs120.zip


#8

i’m searching about this appcrash and found this website
so, i tried as they said

Open the Startmenu and click Control Panel
Browse to System Maintenancethen System
In the left side, select Advanced System Settings
System Properties Window comes up. Select the setting from the top named Performance.
Select Data Execution Prevention.
Select Turn on DEP for all programs and services except those I select.
Use the Browsebutton to locate your file. I my case my internet explorer is not working so I’m searching for main internet explorer file and makes it in exceptions list.
Click Applyor OK .

after that it works just dont know why but my other some program’s starts to showing this error too
thanks for your help


#9

maybe i should need to reinstall my windows 7
what did you say?


#10

That’s very weird. I have DEP enabled here (for essential Windows programs and services only) and never had any problem running appleseed or any other program for that matter:

I wouldn’t advise reinstalling Windows, unless you have many other problems than just appleseed not running.


#11

thanks man, i think installation is the only option what i’ve left with. :sweat_smile:


#12

Is there an SSE2 build for Linux? I probably should have looked deeper before posting this. I’m trying 1.2 to see if that works.


#13

Nope, the current Linux binaries are using (a very small amount of) SSE 4.2. Does this cause issues on your machine?