appleseed 1.9.0-beta won't open any file


#1

Hallo
Im new with applesed studio and I my do something wrong… i normally using cycles for render, and i want try applesed studio.
I tray open several files with applesed studio but they dont open.
Even the obj. file dont open.

Wchich files are opening with applesed studio?


#2

Hi @Blenderuser,
Appleseed Studio reads appleseed project files and is not meant as a content creation application.
It is mainly used for changing render parameter or debugging but not for scene editing or development.
For Blender use the blenderseed plugin from here: https://github.com/appleseedhq/blenderseed/releases
You can use then appleseed similar to Cycles from within Blender.
It is also possible to export an appleseed scene file and render it in Studio.


#3

I installed applesed plugin on blender 2.79.
i works, but not properly.
i cant use a HDRI map for render with applesed.


#4

To use HDR for image based lighting in blenderseed you need two steps (see screenshots):

  1. Load your HDR image file in a free map slot for the world environment and name it
  2. In the Blender World menu select Environment Type and choose HDRI Environment. Then select the hdr map you have previously defined in the map slot.

world


#5

Thanks Mango3
Hdri Works

But Renders on aplessed are extremely slow…
On Cycles I using GPU GTX 1070…
Apllesed is good only for caustic.


#6

I have to disagree somehow. While it is true that Cycles is faster in most scenes, appleseed is not as you have stated “only usable for caustics”. It has very efficient motion blur and OSL shader implementations among other things Cycles does not have.
Now appleseed is a cpu only render with an emphasis on vfx/animation similar to the commercial heavyweights Arnold and Pixar’s RenderMan.
The render speed depends on your type of scene and obviously on the cpu. Appleseed does not use your powerful GTX 1070 GPU. But you can use the built in denoiser to cut considerably render time.


#7

I often render glass objects and transparent plastics. That’s i need caustic which is in applased.
Normally my object standing on white background.
In appeased witch white background i have poor effect. Even when i do 50 passes and 256 samples.
What should i do for good effect? More passes or more samples?


#8

With SPPM, use very few samples per pass (maybe 2 or 3) and increase the number of passes. Try also increasing the number of photons per pass. More tips here: Fracture Modifier branch of Blender


#9

thank YOU
today I will do render with 1000 passes and 3 samples.
One glass and one transparent plastic with sun and one reflector…
In morning I will see result.


#10

Hallo
Now is morning. And I done test render picture. 1000 passes, 3 samples
An effect isn’t good to me.
The floor is plastic Brdf and this surface looks ugly.
this is picture: http://pasteall.org/pic/55c42b44153eb8c3ed75abc3c1d1c63e

What I do wrong?


#11

It is hard to tell from an image alone. SPPM is a bit tricky to set up and you may have to experiment with the settings. Some suggestions:

  • Generally, for SPPM if the scene has blotches but little grain, increase the photon count. If the scene is grainy without blotches (your case) reduce photon numbers. There is an optimum ratio of camera rays vs photon number for each pass.

  • Change the lighting settings. Your scene looks quite bright. Apart from the directed spot light you seem to have a very bright ambient light. You may change the number of environment vs direct light photons ratio.

  • If you use a hdr enviroment, use a low-res hdr for scene lighting.


#13

Thanks Mango3
I found what I do wrong.
I change the: initial radius froom 0.005 to 0.8 and render looks good.
I will do final render in the night.
I let You see the result.


#14

Hi @Blenderuser,

The default value for the parameter Initial Radius for radiance estimation = 0.1 % of the scene diameter.
This radius defines the area which connects rays from the camera (camera pass) hitting the scene surfaces at certain points (hit points) with rays from the light sources (photon pass) hitting in their vicinity.

With 0.005 it’s no wonder you got initially bad results. It is advisable to change only one setting at a time and check the render. If you stray too far from the defaults, the render may not converge in a reasonable time.

Glad you got it sorted now :))