appleseed Users Forum

appleseed 2.1.0-beta, Blender issues

Hello AS Team,

thank you very much for this extremely good looking, crisp render - and your effort in producing it.

I took a weekend for my researches and did exercises in order to make it running for my test visualizations.
I am new to AS and i have difficulties to find any kind of tutorial about the concept of this renderer. So sorry if the questions are plausible:

AS Beta 2.1.0, Blender 28 and 28.1 (latest builds)
Windows Ryzom1700X

  1. Setup: Normal Map concept.
    If i am not wrong, the node tree shold be build like this:
    Here is the screenshot and the scene illustrating the setup:

-> Problems: The simple subdivided BlenderSpehere shows smooth shading, but using normal-map it draws faces smoothing groups edgy.

  1. Normal Map ColorSpace Management concept.
    Using NormalBitmap in other 3d applications requires setting Raw/Linear ColorSpace. In Appleseed i see the toggle with “CMS”: does the user needs to toggle it while using NormalBitmap and setup “Raw”? I have tried but i can not deduct what happens, for me it looks random.

  2. asManifold2D: Texcoordination manipulation:
    In the same scene trying to change any parameter of asManifold2D-Node does not affect the appearance.
    It seems as if the asManifold2D is out of function. I was not able to, for example, tile the map 10x10.
    How can the user manipualte texture coordinates in AppleSeed correctly?
    s. the same attached scene as above:

  3. UDIMs: random stops
    Using latest Blender 281, i was trying to engage UDIMs in AppleSeed. While i can get first two materials working, rendering stops after i add any kind of bitmap to the thrid material in the material editor.
    Detaching the bitmap node allows rendering again. It seams I can’t have more then 2 materials with textures in the current version?
    s. scene “02_UDIMs.blend”

  4. Disney SubSurface Param:
    Is there any explanation what it exactly does and how to control it? I notice some slight changes on shading but it is not self-evident how it should be engaged to produce any kind of wax,skin or similar effect (for example parameters about depth, radius or similar)

I know it is beta but we are always happy to get reports during our productions, therefore few things that came up during the work:

  1. Viewport issues and bugs
  • Both MaterialShadedPreview and RenderedPreview show full computation of the scene. Material should be non-rendered preivew with only materials.
  • While having RenderViewport, switching HDRis and/or constant/none/hdri causes randomly instant crashes
  • Viewport renderer continues rendering viewport after pressing F12. The computer spend CPU now on both screens instead of pausing view-port in favor of Image Rendering.
  • Attaching and detaching nodes randomly does not affect viewport render (s vid_01_Appleseed_viewport-refresh.mp4 - in folder

Thanks for the feedback. I’ll try to answer some of your questions:

On the normal map appearance, you seems to have shadow termination issues. Even with smooth shading you will see that if your sphere is too coarse geometry wise.

For the Disney shader, we use the older ‘true’ model in that the ‘subsurface’ control is a diffuse shading trick that is supposed to give the illusion that there is true SSS going on. It’s a complete hack and is very subtle. It’s not all that useful in practice.

Normal maps should not need the CMS system. If it is not used appleseed will treat the texture as raw (or linear).

UDIMs are funky. I’ve never used them so I’m not sure what the cause of your issue is (although I suspect it’s something with our shaders and not necessarily Blender)

MaterialShadedPreview requires GLSL shaders to function I believe. We do not have these currently.

The node connections are a known issue.

Viewport rendering not ending is a Blender bug. In 2.8 the render engine instance that is created for interactive mode is not properly stopped or destroyed when viewport mode is ended or something else happens. Unfortunately I don’t see an easy fix for this one.

1 Like

Hi Igor,

welcome to our forum and the very detailed report you made. It is really helpful for us to get detailed feedback about usability issues and bugs.

Some general tips:

  • Have a look through the forum, many issues had been discussed here.
  • The shader documentation explains the parameter of each shader
  • For the asTexture built in color management read this detailed explanation
  • You are very welcome to join our discord server and get live access to talk to the developer and internal developer builds

We will have a more detailed look at your issues and will respond when time allows.

1 Like

Hi Igor,

As Jon explained, this is a typical artifact caused by normal maps. There’s a new paper that should provide a decent solution to this problem but so far I haven’t been able to get proper results. I expect some progress on this front soon.

I would be curious to see how other renderers (e.g. Cycles) fare on this exact same scene (low poly sphere + normal map). I’m expecting that they would show similar artifacts. Would you mind trying and posting a render here?

Cycles recently (early August) got the shadow terminator fix added to its code:

Very interesting. I’ve tried to implement it but my results weren’t satisfactory. I must be missing something obvious. I would appreciate someone looking at my implementation :slight_smile: I’ll create a channel on Discord where I’ll post my results and where we can continue the conversation.

Hello Franz,
thanks a lot for taking time to look into it.
I was intrigued too, and I have taken this evening to check your inquiry. You are apparently not the only developer facing this issue. Last time, 4 years ago, I did almost the same copy&paste post in Corona forum. The good news is - it is fixable. But don’t ask me how I wish I could program :frowning: .

The first observation is the circumstance in which this happens. In the first run, all other renderer in Blender (Cycles, Eeeve, RadeonPro, LuxCore…) have rendered optimal smoothed surface. This was not the case with AppleSeed, it showed prompt the smoothing-groups.

By coincidence, I have then changed the point light size from default 1m to 0,001m.
From this moment some renderer started showing similar or same artifacts. Appleseed draws them most intensive, but the rest has it on exactly the same place.

It seems AppleSeed point light is infinitely small. The problem is that even Appleseeds’ Rect- and other lights show these artefacts, while they are not visible in other Blender renderer.

Here are the Looks:

Cycles with 0,001m point Light. Visible Smoothing Groups. Maybe there is something new in 281 but i can not run it now. Note: these artifacts disappear as soon as the point light get some size like 0,1 and bigger.

Eevee with 0,001 Light

LuxRender (current Beta) with 0,001 small point light

RadeonPro with 0,001m point light.
Apparently, the RadeonPro is the only renderer which shows smoothing groups in rendering.

hope this helps for the start.
best regards

Here is the line up:


Hi @Igor_Posavec,

A fix for the shadow terminator artifact (the one you get even without using bump or normal maps) is underway.

Feel free to ping us on Discord if you don’t hear from us in this thread within a few weeks, or if you want to test a development build of appleseed with this fix (that would be appreciated!).

1 Like

Hello Franz,
you are awesome. I jumped now for the first time into Discord, have a lot to catch up…
thanks - and as soon as you have some new builds, please add me to the update list!
best regards