appleseed Users Forum

blenderseed 1.0.0-beta issues on Ubuntu


I work on Ubuntu 18.04 64bits, blender 2.79

I have downloaded and install/unpack appleseed 2.0.0 beta and

The command in a terminal seems to work fine (I’m newbie in applessed so I just can say that the gui is launched without error).

I put the blenderseed folder in /usr/share/blender/scripts/addon directory

Then, I run blender, Ctrl + Alt + U, see the Render options and see blenderseed.

When I try to enable the blenderseed render, I have the following message in the terminal :

Read prefs: /home/olivier/.config/blender/2.79/config/userpref.blend
RNA_def_struct_ui_text: 'Class for appleseed node tree.' description from 'AppleseedOSLNodeTree' '' ends with a '.' !
Writing: /tmp/blender.crash.txt
Erreur de segmentation (core dumped)

And blender crashes…

If anyone have an idea, it will be very appreciated,


Hi Uta,

Welcome to the appleseed forum!
Can you provide some more information on the crash. Maybe there is something in the /tmp/blender.crash.txt

One note, blenderseed works only with the 2.79b official versions, not the daily builds which use a different Python version internally.
You can check which Python version Blender uses in the built in Python Console (see screenshot)
For blenderseed to work it needs to show major=3, minor=5 which means Blender uses Python 3.5.

I am on Ubuntu 17.04, Blender 2.79 official.
When I try to activate Blenderseed1.0Beta, I get this error.

Traceback (most recent call last):
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/appleseed/lib/appleseed/", line 35, in <module>
    from _appleseedpythonbuiltin import *
ModuleNotFoundError: No module named '_appleseedpythonbuiltin'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/opt/blender/2.79/scripts/modules/", line 370, in enable
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/", line 64, in register
    from . import export
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/", line 33, in <module>
    from .translators import SceneTranslator
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/translators/", line 29, in <module>
    from .scene import SceneTranslator
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/translators/", line 33, in <module>
    import appleseed as asr
  File "/home/maj/.config/blender/2.79/scripts/addons/blenderseed/appleseed/lib/appleseed/", line 45, in <module>
    from ._appleseedpython3 import *
ImportError: /lib/x86_64-linux-gnu/ version `GLIBC_2.27' not found (required by /home/maj/.config/blender/2.79/scripts/addons/blenderseed/appleseed/lib/appleseed/../

Hi Bobar,

Thanks for reporting and welcome to the appleseed forum!

From the error-log I see that GLIBC 2.27 was not found. You state that you use Ubuntu 17.04 which uses an older version GLIBC 2.24 according to
So it is most likely an incompatibility with your system GLIBC and the newer one blenderseed was linked with. We will discuss what can be done in a cases like this and get back to you.

After a discussion it emerged you have two options:

  1. Upgrade your Ubuntu to a more recent version
  2. Build appleseed yourself from source with your current system
    (See documentation on how to do it:

Good day.
I am an industrial designer.
It is important for me to have excellent visualizations.
Decided to try your render.
The blender issues this console:

  Traceback (most recent call last):
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/render/", line 137, in view_update
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/render/", line 287, in __start_interactive_render
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/translators/", line 204, in translate_scene
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/translators/", line 421, in __create_translators
    super(SceneTranslator, self)._create_translators(self.bl_scene)
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/translators/", line 217, in _create_translators
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/translators/", line 235, in __create_material_translators
    mat_key = ObjectKey(mat)
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/translators/", line 49, in __init__
    self.__name =
AttributeError: 'NoneType' object has no attribute 'name'

location: <unknown location>:-1

Traceback (most recent call last):
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/render/", line 145, in view_draw
  File "/home/dez/Soft/Blender/blender-2.79b/2.79/scripts/addons/blenderseed/render/", line 358, in __draw_pixels
    self.__tile_callback.draw_pixels(0, 0, width, height)
AttributeError: 'NoneType' object has no attribute 'draw_pixels'

location: <unknown location>:-1

Hi dez,

Welcome to the forum!
I hope appleseed will be useful to your industrial design projects.
Seems like you used the new build with fast C++ based exporter.
The issue with blenderseed you reported is known to our developer @Jonathan_Dent
A fix is in the works. Thanks for reporting.

I am using Ubuntu 18.04
Blender 2.79.b official, not PPA
no special assembly …
Email me when the problem will be solved?

Ah, my fault. I assumed you used blenderseed in Windows because we have seen a similar error there with the new exporter.
We let you know when we have an updated Linux build ready.

Well thank you.
I will wait. A lot of work. Need speed and quality above Cycles. Quality is like a Corona, like a Luxcore.
Really looking forward to.

Hi @dez, welcome!

Just to keep expectations in check: appleseed is likely to be slower than Cycles (appleseed is CPU only while Cycles is CPU and GPU). However we are planning more work on the visualization front, something that Cycles is unlikely to offer in the short term.

Rendering time is not important.
my time is important.
I see that your render is easily customizable. looked at the materials - pretty light.
but I can’t check it yet.
PS: are user normals supported?
Is the date transfer modifier relevant?

1 Like

Hi. This is a different error. It’s saying that our export object name generator isn’t finding something it needs. Could you post the scene you’re trying to render?

test scene:

the object on layer 2 is rendered.
object on layer 1 - error

i guess i found a reason.

While I was posting a video on YouTube, I noticed another moment - if there is no camera in the scene, an error will occur

Hi @dez
Thanks a lot for testing. In blenderseed a camera needs to be in the scene to render. If you press Render it will show a warning that no camera is defined. However, the preview render does not show such a warning and the UI will just black out. This is a known bug and had been filed as an issue in the bug-tracker at GitHub.

and free material slots cause an error.

Compositing window does not open. I can not without compositing

This is another bug that’s been fixed. I’ll be posting a preview update with a bunch of bug fixes. Or you can download the latest Github master branch and copy the ‘appleseed’ folder from your 1.0 download into it.

Thanks for the answer.
I do not understand what to download and where to insert it.
I tried to download it:
And paste in BlenderSeed folder.
An error has occurred:error

I’ll be waiting for the new BlenderSeed