appleseed Users Forum

blenderseed 1.0.0-beta issues on Ubuntu

New preview build. Camera and compositor bugs should be fixed.

This is a topic about Ubuntu, you gave me a build of Windows.
But I tried it anyway.

I have 14 scenes.
There are 7 cameras in each scene.
Each camera needs its own HDRI settings.
how to be?

With the latest version of blenderseed (master, link is below) you can have several HDRI in your world environment defined.

new material - error

Can you try to use this as_closure2surface.oso. Just unzip it and copy it into /scripts/addons/blenderseed/appleseed/shaders/ (554 Bytes)

Whenever possible, it’s best to use fully packaged development versions of blenderseed instead of downloading the blenderseed repository (which is changing all the time and may not be all that stable).

Those development versions can be found on Dropbox:

Here’s the latest Windows build to date; it fixes the as_closure2shader bug:

That said, as you appear to be on Linux, you probably have no other choice right now than assembling your own blenderseed.

Thank. I know.
I like the image from Apple Seed.
I like a lot about this rendering.
I like the responsiveness of your team.
I help the project with what I can - I check for errors.
I check in the work.

PS: Luxrender somehow learned to show shaders in the 3D viewing window.


That’s hugely appreciated, thanks for taking the time!

the latest build can create various presets World HDRI.
can create various materials.
But not rendering.
is it something in my operating system, or do you not check it yourself?
does not work only for me?

Please be more specific about what you’re trying to render. Or better yet, post the scene so we can take a look at it

1 Like

I can not give the scene.
I will try to explain with words.
I open the old scene in a new assembly of Apple Seed. And I run the rendering.
Render does not go. The console is all red.

Thanks @dez, we’re looking into it. We may need more info, in which case we’ll ask here. Thanks again for your time and sorry about the troubles.

1 Like

Are you using asMetal anywhere?


A change was recently made to this shader that removed a parameter. Blender saved that osl parameter with your file so it’s trying to access something that doesn’t exist now. Delete the existing asMetal node and add a new one. That should fix it.

Yes, the metal had to be replaced.
I was unable to start the workflow again - the Gamma node stopped working. And I have it very much used.

The Gamma adjustment node I provided you informally as a quick fix is not part of the official appleseed/blenderseed distribution. Therefore whenever you install a new blenderseed version (which overwrites your current appleseed shader) you have to be sure that the as_gamma.oso is back in the /addons/blenderseed/appleseed/shaders directory. That means you may have to manually copy it again there.

1 Like

@dez: As Jon said, we have identified the problem (GitHub ticket) and we will fix it.

1 Like