appleseed Users Forum

Blenderseed lock up with internal rendering


#1

Hi, I’ve been trying to use the most recent release of Blenderseed (from September of 2014) and I’m having some real issues trying to get the internal rendering mode to work, which is the only way to do animations from what I can see. It seems that the render will hang at a random spot and stop updating. Sometimes it gets 60% through the image, sometimes only 15%. Pulling up the windows task manager shows that the Appleseed CLI is still active, but the CPU activity has stopped, and it never recovers. This happens almost every single time I try to render. Occasionally a frame will finish, but it’s very rare. Is this an issue that only crops up on Windows or is it across all platforms? I’d really like to experiment with Appleseed animations through Blender, but this bug makes that pretty much impossible. Exporting to Appleseed Studio seems to work fine.

Any help would be great. I hope this doesn’t sound like a slam on Joel (the Blenderseed author), as aside from this the exporter works really well.

Edit: There also seems to be another bug in the internal rendering mode that causes the Appleseed CLI to not fully utilize my processor. CPU activity site in the 50 to 60% range instead of the 100% that Appleseed Studio uses.


#2

Hi Jonathan,

Sorry for the delay, many of us were at the FMX conference and we’re still catching up!

I’ve pinged Joel about the blenderseed problem you reported. I’m not sure what’s going on, you’re the first one to report the issue.

Franz


#3

Which Blender version are you using?


#4

Hi John,

I can reproduce the problem on 64-bit Windows 8.1, using Blender 2.74 and blenderseed 0.3.6.

We’ll get back to you.

Franz


#5

You beat me to it. I am using Windows 7 64 bit, Blender 2.74 and the latest official release of Blenderseed. I noticed that the ‘official’ supported version is 2.71 but I didn’t even think of that at first since the rest of the exporter worked just fine. Maybe when it comes to internal rendering the version really does matter…

Normally I use the plugin to export the geometry and then I render in Appleseed Studio, but in this case I wanted to test out an animation, and internal mode was the only way to do that short of manually exporting every frame (and taking the disc space necessary for that)


#6

I seem to have found a workaround for the “lock up” problem: it’s not really appleseed locking up, but rather blenderseed not getting all the tiles back, or not displaying them for some reason. I could circumvent the problem by increasing the Refresh Time to 2 seconds (default is 1 second). It seems to work fine here, every time.

Regarding CPU utilization: on trivial scenes, appleseed may indeed fail to reach 100% CPU usage. On any other scene, it should definitely reach full CPU utilization if the number of render threads set in blenderseed’s UI matches the number of logical cores in your computer.

Franz


#7

I’ll test it out tonight. Thanks for looking into this Franz!


#8

Hi, sorry for the delay! I can reproduce this as well; I actually don’t know what’s causing this. I never experienced this in pre-2.74 versions. I once rendered an animation using appleseed.cli from Blender, so I know this used to work just fine prior to 2.74, and the only thing I believe that’s changed is Blender. I know a lot of people have reported crashes on OSX and maybe even Linux when the refresh time is set low, so this may be the equivalent of that behavior on Windows…

I’m wrapped in a project right now, so I can’t get to this right away, but I’ll take a look at it when I can.


#9

Hi guys,
Switching the refresh time didn’t fix it for me. I had a render fail three times in a row. I’m going to try downloading Blender 2.71 to see if that might make a difference.

Edit: Out of five attempts with 2.71, it failed four times. I even tried putting the refresh time to ten seconds. Watching the task manager gave some clues to behavior. Contrary to what I said earlier, the Appleseed CLI doesn’t hang and stop rendering. Instead it appears to randomly stop and shut down at some point during the render, almost like it gets confused and thinks it’s done. Given that, I’m not sure the problem is 100% with Blenderseed.


#10

@Jonathan_Dent That’s interesting, I don’t see why or how appleseed.cli would stop rendering before completion, AFAIK there are no ways for Blender / blenderseed to tell appleseed.cli to stop, the way it is currently implemented.


#11

It is an odd behavior. I tried it on a Linux Mint box and it worked just fine (even with the refresh at 1 second), so I tried wiping and re installed Windows 7 only to have the same glitch happen. So ultimately it may be OS related…

BTW, interesting observation during this: Appleseed seems to render noticeably faster in Windows. Using my test model in Appleseed Studio I got 5 minutes on Linux and 4 minutes on Windows. That’s the opposite of what I usually see. Not sure if it’s a fluke since I only ran the test once…


#12

Hi, I got the same error, is there any good news?


#13

Not yet. Sorry.
We’ll try to fix it as soon as possible.


#14

Just for curiosity, I tried the latest version of the exporter with the new 1.2 beta on Blender 2.74 and the behavior is still present.

Just a thought: it appears that the exporter utilizes Luxrender’s pylux module for material previews and interfacing with the cli renderer. Lux has been changing a lot of stuff around lately due to their LuxCore development. Is it possible something changing in Pylux is causing the error? I also noticed the newest version of the exporter doesn’t allow for anything other than internal rendering (as in the option to export to Appleseed Studio is gone). Is that intentional?


#15

Blenderseed does not use Luxrender or pylux.

The version on github?

Est.


#16

Yes, the Github zip file.

I was wrong, I saw something in the log window that led me to think it used pylux.


#17

Interesting development… I downloaded a new copy of the ISS model I’ve been using to test Appleseed. This time, instead of using one file for all the render engines I play with (LuxRender, Cycles, Mitsuba, Appleseed and PRMan) I created one file for the Appleseed test and didn’t create any shaders for the other engines. Now the internal render mode seems to work fine, for the most part. I crashed it once with refresh set to 1 second but it succeeded the five times I fired off a render with a 5 second refresh rate.

However, this is the first render I’ve done with Blender 2.75a and the new Appleseed beta release so maybe something changed there too.