appleseed Users Forum

Can appleseed load an arbitrary point cloud?

Hello,

I’m brand new here and had a basic question.

I was wondering if Appleseed can load a point cloud (ply file)? (Unfortunately, I’m having some trouble installing Appleseed, so I’m unable to try this out myself right now.)

I’m looking for a rendering engine that handles arbitrary point clouds and has good rendering characteristics, especially when the data may have “holes”. Eg. it would fill in holes in a very natural way. Can Appleseed do that?

Thanks,
~ Dan

Hi @dkoppel,

welcome to our forum!

appleseed has not yet native support for point cloud rendering. Some render engines have this feature e.g. Arnold or V-Ray or in the past Mental Ray & IRay.
One way to overcome this would be using photogrammetry software to construct a dense point cloud (e.g. in Alembic format) and further get a textured mesh.

Concerning your troubles to install appleseed. Can you give some information what is the problem. Are you talking about appleseed-core & studio or about one of our plugins for Blender, Max or Maya?
You can download the latest binaries from our GitHub release page:
https://github.com/appleseedhq/appleseed/releases

Hello,

Thanks for all your useful tips concerning other engines with point cloud support.

In response to your question about why the Appleseed binary wasn’t running on my system, I downloaded the “core engine” binaries from https://appleseedhq.net/download.html. I’m running Ubuntu 16.04 and I got the following error running appleseed.studio on the command-line:

./appleseed.studio: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by ./appleseed.studio)
./appleseed.studio: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /home/dkoppel/Downloads/appleseed/bin/../lib/libappleseed.so)
./appleseed.studio: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.25' not found (required by /home/dkoppel/Downloads/appleseed/bin/../lib/libexpat.so.1)

My coworker ran same program on his Ubuntu 18 and it worked. Do you know what I must do? The files listed in the error message exist on my system.

Thanks,
Dan

Have a look at this thread, it explains the reason why appleseed-2.0.0-beta is not running on Linux system with older glibc versions (2.1.x) like CentOS 7.x or Ubuntu 16.04.
https://forum.appleseedhq.net/t/linux-glibc-2-27/914

Thanks, Herbert!

When is Appleseed 2.1 being released?

1 Like

We are in the process of getting Linux builds ready. Windows builds are already on GitHub (see this thread): https://forum.appleseedhq.net/t/can-appleseed-load-an-arbitrary-point-cloud/912/2

Thank you Herbert!