Can't render whisky_glass.appleseed - disney_material missing


#1

Hello all. I just built Appleseed 1.9.0-beta from source on NixOS (may I just compliment the devs here for having a far cleaner build than LuxCoreRender?). appleseed.studio is able to load the Cornell Box and render this, so the installation seems okay as far as this goes.

I downloaded the Whisky Glass project from here and tried to load whisky_glass.appleseed from it, but it complains that “disney_material” is invalid. I see the same error if I try to run appleseed.cli whisky_glass.appleseed; in specific:

2018-06-09T21:05:38.799391Z <001>    45 MB info    | loading project file whisky_glass.appleseed...
2018-06-09T21:05:38.802226Z <001>    47 MB error   | while defining material "table_mat": invalid model "disney_material".
2018-06-09T21:05:38.802460Z <001>    47 MB info    | loaded mesh file /home/hodapp/source/appleseed-scenes/scenes/whisky_glass/geometry/Box001.binarymesh (1 object, 8 vertices, 12 triangles) in 0 ms.
2018-06-09T21:05:38.802576Z <001>    47 MB info    | loaded mesh file /home/hodapp/source/appleseed-scenes/scenes/whisky_glass/geometry/Light001.binarymesh (1 object, 4 vertices, 2 triangles) in 0 ms.
2018-06-09T21:05:38.811326Z <001>    49 MB info    | loaded mesh file /home/hodapp/source/appleseed-scenes/scenes/whisky_glass/geometry/glass.binarymesh (1 object, 11,727 vertices, 23,450 triangles) in 9 ms.
2018-06-09T21:05:38.821479Z <001>    53 MB info    | loaded mesh file /home/hodapp/source/appleseed-scenes/scenes/whisky_glass/geometry/icecube.binarymesh (1 object, 13,826 vertices, 27,648 triangles) in 10 ms.
2018-06-09T21:05:38.823095Z <001>    53 MB info    | loaded mesh file /home/hodapp/source/appleseed-scenes/scenes/whisky_glass/geometry/whisky.binarymesh (1 object, 2,243 vertices, 4,482 triangles) in 1 ms.
2018-06-09T21:05:38.823816Z <001>    53 MB info    | scene bounding box: (-1358.989990, -824.705200, -1406.587769)-(1365.050049, 1196.545166, 385.206268).
2018-06-09T21:05:38.823816Z <001>    53 MB info    | scene bounding sphere: center (3.030029, 185.919983, -510.690735), diameter 3836.192627.
2018-06-09T21:05:38.824602Z <001>    53 MB error   | failed to load project file whisky_glass.appleseed (1 error, 0 warning).

What am I doing wrong here?


#2

Hi @Hodapp87,
Interesting, I haven’t heard of NixOS until your post.
When you compile from source please check with cmake-gui if you have enabled with Disney Material in the cmake build configuration (see screenshot) . By default it is not included. It is also a very convenient way to change build parameters and compiler flags.


#3

Thank you - that was the issue! I looked at Building appleseed on Linux, but I was dealing with CMake more manually and not via the GUI, and I had somehow managed to completely ignore the WITH_DISNEY_MATERIAL option. It’s now working.

As for NixOS, I will probably do a pull request soon for Nixpkgs so that it contains a package for Appleseed (and for some other dependencies it is missing, like OSL and SeExpr).


#4

That would be much appreciated, thanks!


#5

I did that pull request and it was accepted, so Appleseed is now in Nixpkgs (here) and should be built as part of (I’d guess) 18.09 once that’s released. I’ll do my best to keep updating this with newer Appleseed releases as they come.


#6

Fantastic, thanks a ton!