appleseed Users Forum

Can't run appleseed 1.5.0-beta on Windows 7 [SOLVED]


#1

Hi all.

I would like to take Appleseed for a spin at our office, but I am having trouble getting it to run.
Im on Windows 7 doubleclicking the appleseed.studio.exe.
Nothing happens. No popup, No error. Nothing.
Tried both regular + SSE4.2.

Any way to get error logs or something to you that you can use to pinpoint the issue?
What info do you need?

Best regards.

Ejnar Brendsdal.


#2

Hi Ejnaren,

That’s weird, let’s investigate.

Can you open a Command Prompt in the bin directory and type

appleseed.cli.exe builtin:cornell_box -o cornellbox.png

That should render the built-in Cornell Box scene and write a cornellbox.png file on disk.


#3

That results in a appleseed.cli.exe process running. no CPU resource running it though but about 2.068 Kb memory usage.
Upon closer inspection the appleseed.studio.exe is also running as a process. But no Application or windows appear.

And apparently no cornellbox.png is coming out of it…
Any way to get logs?


#4

Ok, this is getting interesting :slight_smile:

There are no logs written to disk.

Could you try something simpler?

appleseed.cli.exe --version --system

#5

Same effect.
An appleseed.cli.exe process begins but never ends. Returning no feedback from the command prompt. The prompt turns unresponsive until I manually end the process running.


#6

PS. I am on my way home nut can continue trying out on this machine tomorrow.
Maybe I can try on a different machine when I am home tonight.


#7

Do you have an antivirus running? Could you try running appleseed.cli in a Command Prompt with elevated permissions (administrator mode)? Or run appleseed.studio as administrator?


#8

It could be some config stuff from the IT admins (I work at a fairly large arch company in Denmark C.F.Moller). I have never had any problems running other rendering apps though so its a bit curious.
Ill try on a different win machine later to check.


#9

Just to answer the question. McAfee is running but appleseed.studio as admin gives same (zero) result…


#10

Windows has an (interesting) way to know that a program was downloaded from the Internet; maybe some policy at your company prevents certain binaries from running if they were downloaded, but that sounds unlikely.

I’ll try to locate a Windows 7 machine to see if the problem is related to that particular version of Windows.


#11

Well it runs fine on My home machine. Although that is a win 10 machine. It does show that I’m doing the right thing…


#12

Good news, thanks for the update!

I’m still trying to get my hands on a Windows 7 box. If I don’t manage to repro the bug, it would be really nice if you could run Process Explorer (awesome Microsoft utility, single .exe, no installation required) on your work machine so that we can check what the process is doing…


#13

Its downloaded. Anything specific I shouldI do for it to help you figure out whats going on?


#14

Awesome.

Could you start appleseed.cli in a Command Prompt:

appleseed.cli.exe builtin:cornell_box -t 1 -s 10000 10000

(-t or --threads sets the number of threads, here 1 to make things easier to understand; -s or --samples allows to set the min and max numbers of samples; here we use large values to make sure appleseed.cli runs long enough.)

Then locate the appleseed.cli.exe process in Process Explorer, right-click on it, choose Properties, make a screen capture of the Threads tab and paste it here.

Let’s see if we can figure out what’s going on! If not, I could send you a debug build of appleseed that would give more info.


#15

Check! Here we go:


#16

Thanks! I will investigate and keep you posted here (today, hopefully).


#17

If you can afford spending a few more minutes on this, here’s what would be even more helpful (someone suggested this, I hadn’t thought about it):

  1. Download Process Monitor (another awesome tool from the same guy at Microsoft, single .exe, no installation) and start it.

  2. Upon startup, a Process Monitor Filter dialog opens. Add an entry of the type “Process Name is appleseed.cli.exe” and click Add. It should look something like this:

  3. From this moment on, Process Monitor is recording everything that appleseed.cli does (or will do). Start appleseed.cli with the following command line:

     appleseed.cli.exe --version --system
    
  4. A bunch of events should have appeared in Process Monitor. Go in File → Save to save the trace in PML format, then attach the file here.

Thanks for your help!


#18

No worries. I would like to get it to work.
Heres the pml: AppleseedCliProcess 01.PML (5.0 MB)

Edit: It writes that it shows 409 of ~1.7 mio events…after a couple of minutes processtime…


#19

Great, thank you!

I think what Process Monitor tries to say is that only 409 events are related to appleseed.cli.


#20

I’m having the same issue. Downloaded 1.5.0-beta (non-SSE), extracted, ran appleseed.studio.exe. Process appears in task manager but application UI doesn’t appear. This is on Windows 7 64-bit. Tried running as administrator, no luck. Antivirus is disabled.