Can't run appleseed.studio from 1.9.0-beta on macOS 10.13.5


#1

I have a nearly stock OS X High Sierra (10.13.5) installation here - it was installed from scratch just yesterday and I’ve not had occasion to install anything else than Chrome and Firefox.

When I try to run bin/appleseed-studio from the archive (whether from commandline or Finder), I see this message, followed by it exiting:

Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
ImportError: No module named site

I don’t see anything in instructions about having to install separate Python. What am I missing here?


#2

It looks like the macOS build of appleseed doesn’t bundle Python 2.7 like it’s supposed to. My mistake. You might well be the first person to use appleseed without having Python 2.7 available…

Thanks for the heads up, I’ll fix this as soon as I can. In the meantime, can you install Python 2.7 and check that it fixes the problem?


#3

Here are build instructions for the MacOS build of appleseed. If you don’t want to build from source then the part about Python 2.7 installation may be helpful.
https://github.com/appleseedhq/appleseed/wiki/Building-appleseed-on-macOS


#4

I think just installing Python 2.7 should be enough. Building from sources is a whole other level of pain… :slight_smile:


#5

I installed with brew install [email protected], logged in and out, verified that running python shows the newer version and import site works, and I still see the same error.


#6

Ok, will investigate and report back here. Thanks for the report.


#7

It looks like appleseed is not aware of your python installation. A quick thing to try would be to set explicitly the environment variable $PYTHONHOME to your local python root folder.


#8

I don’t really know what directory is expected here. brew info [email protected] pointed me to /usr/local/Cellar/[email protected]/2.7.15_1, so I attempted setting the value of PYTHONHOME to that. The only result was that the error about $PYTHONHOME went away, but the ImportError remained.

Interestingly, if I try to run python while this variable is set, it gives the same error. Trying to figure out why now.


#9

I was able to successfully run Appleseed Studio by setting PYTHONPATH (not PYTHONHOME) to /usr/local/Cellar/[email protected]/2.7.15_1/Frameworks/Python.framework/Versions/2.7/lib/python2.7.

I’m still not sure why this should be necessary. If I just run python on its own and inspect sys.path, that directory is already present - so clearly it finds its way to that directory with no problem.

I’m also not sure why the error recommends setting PYTHONHOME, but as far as I can tell, that error isn’t coming from Appleseed.


#10

Thanks for the details, and glad that you managed to run it!

According to Python’s documentation, PYTHONHOME is the location of the standard Python libraries while PYTHONPATH allows to augment the default search path for module files.

If I just run python on its own and inspect sys.path, that directory is already present - so clearly it finds its way to that directory with no problem

Maybe Python does already have this path in sys.path but when Python is embedded inside appleseed.studio it doesn’t? I’m not quite sure to be honest.

Maybe @est has an idea?