Can't see appleseed lights or materials


#1

Good morning,
Please after installing appleseed for 3dsmax, under the create panel, under lights I could only see the default 3dsmax lights or standard lights and no appleseed lights.

Also my balls in the material editor compact mode are all black plus shaders in material map browser.

What should I do ?


#2

That’s something that needs to be changed, on the meanwhile you can use some max lights. But just to recall these are not physical lights, try to use the light material to create geometric lights. Also only appleseed materials are compatible with appleseed.


#3

Thanks


#4

Please I downloaded a bsdf file which is a file with so many numbers that can be edited in notepad.
How can I use this file in appleseed ?
Do I need python script or max script ?
Is the file useful at all ?


#5

You don’t need to concern yourself with bsdf files. These are the material implementation source files.
All appleseed materials are available in the material editor in Max.
if you want to add a light – e.g. a spotlight – just use a Max standard light as @juancarlosgzrz has explained above (see screenshot)
Capture

You can also apply an appleseedLightMaterial to any geometry object and it becomes an emitter, similar to an incandescent lamp.


#6

thanks


#7

Hi good day, please I need a solution to this problem.
The material balls are black and I cant see any material I create. What do I do ?


#8

Hey I already answered your question. As I said above:

You need to use appleseed materials, the ones you are using are bundled with max and therefore not compatible.


#9

Hi ebanji,
In the material editor (the screenshot you posted above) you need to press the button “Physical Material” in your example and then from the menu which comes up select one of the appleseed material (see my attached screenshot). After this you will see that the material preview changes from black to the proper one.


#10

Thanks very much.
I am now clear.


#11

Please I want to know what camera works with appleseed.
Please help me with settings.
Anytime I render its like this .
After assigning default diffuse Disney material appleseed%20test


#12
  1. Best is to delete all cameras you had left over from your imported scene. Appleseed does not yet support the Max Physical Camera
  2. Adjust the scene view how you want it to be rendered
  3. Create -> Cameras -> Create Standard Camera From View
  4. In the Render Setup -> View To Render: select Quad4-Camera001 (see screenshot)

Capture


#13

Actually it does, it just doesnt’ support all the parameters. Dof is supported for example.


#14

Thanks.
I will try this.