Error with Blender


#1

Hi to All,
I’m new and I try to test Appleseed with Blender.

I opened a old scene with cycles and coverted all material, but I’ve some problem.
Moreover i don’t see the input node to work by node editor…

Here the screenshot




#2

Hi Magog,
I had once a similar error, Blender didn’t show the OSL surface shader in the node editor but the other OSL shader were there.
I copied the as_closure2surface.oso file from appleseed\shaders\blenderseed directory into the blender-2.79b-master\2.79\scripts\templates_osl\ directory and restarted Blender. After this Blender was able to load correctly the OSL surface shader.
I don’t see this behavior anymore, maybe you try to reinstall with the newest version of Blenderseed from Github.


#3

SO…
I solved with the Editor Node… But I don’t know how… :grimacing:

In the simple scene I don’t have problem, now I don’t understand the issue in the old scene…

Tnx Mango for your answer!!!


#4

Glad you got it sorted :slight_smile: . Please keep asking if you find some oddity or for suggestions/improvements like in your other thread. It’s a very friendly community here and contributions keep the forum a lively and interesting place.


#5

Of course!
I also solved the problem changing the chair (with a similar model) but I still don’t understand how the mesh made this issue.