Glass setup


#1

Hi there. I`ve tryed to set up scene with some glasses in it, and immediately failed with transparency depth.


I forgot to say, It`s in Blender


#2

Hi @Volden,
Welcome to the forum and thanks for showing a render!
Some tips for your scene:

  • increase the Ray Depthin the asGlass material
  • for intersecting dielectrics (e.g. liquid inside a glass) use differentNested Glass Priority settings in the Object Properties panel. (e.g. 0 and 1, higher number takes priority)
  • set Max Bounces for Photon Tracing and Radiance Estimation high (0 means user-unlimited, but the render engine has a hard cutoff at 100 bounces)

#3

Thank you
I didn`t understood Nested Glass Priority logic. Can you explain?


Playing with SPPM
#4

I didn`t understood Nested Glass Priority logic. Can you explain?

Sure,
when you have a liquid filled glass then the mesh of the liquid and glass would touch without gap and would have coinciding faces. This would lead to precision errors and render artifacts. The solution is to have the liquid mesh slightly larger, intersecting the glass and assign a different medium priority to it, otherwise it would be a mix of glass and liquid. With medium priorities assigned the render engine automatically tracks the correct index of refraction and render artifacts are avoided.

Maxwell Render has a good documentation page with graphics explaining this concept:
https://support.nextlimit.com/display/maxwell4/Nested+dielectrics


#5

Thank you!
I found the solution: the reason was in…walls shader behind the scene. Depth was set to 1, increasing this value lighten the glass


#6

So there is the final result of my 1st look up onto the Blenderseed


#7

Very nice!

There are some kind of artifacts on the silhouette of objects, is that intended?


#8

Nope, I just tested the image quality and rendertime, and this is just to understand some basic principles

Oh, btw, scaling of an object provides some artifacts, f.e. if I didn`t apply scale, mesh starts to render quads instead of smoothing


#9

Can you elaborate on that? Maybe you can provide a simple test scene, or show us how to reproduce the problem?


#10

Yes, sure. APL_scale_tst.zip (1.5 MB)


#11

Thanks!

Out of the box I’m getting this when I render the scene you provided:

Can you explain in a little more details what’s the problem?


#12

The problem is in object`s unapplied scale
And it looks like this:


#13

Thanks, this looks like a bug. We’ll be investigating shortly.

GitHub ticket: https://github.com/appleseedhq/blenderseed/issues/366


#14

Hi Volden,
What version of blenderseed are you using?


#15

So I ran your file through with the latest blenderseed (with the C++ exporter) and I didn’t see any faceting when the object was scaled. If you have an older version that still uses the Python exporter that may be the problem.


#16

I`m using 1.0.0 + Blender 2.79

image


#17

Can you try using the version linked below?

https://www.dropbox.com/s/n31f2fz196i8zvd/blenderseed-1.0.1-beta_11_23_18-win64.zip?dl=0


#19

Hi @surdelmavo

That means that the maximum number of bounces is cut-off by the render engine at 100 in any case regardless that the user has set an unlimited user-bounce limit. If the user has set some lower bounce limits the render engine will terminate the path at the lower setting.
100 bounces is a high number and only in some very specific cases (light transport through light-pipes or optical fibers) one would need higher numbers)