appleseed Users Forum

How to create volumetric lights

I was trying to make use of appleseed and create something delicate. And the area light didn’t work so I used spotlight.


My question is ,how to create volume like this.
Another question is what can I plug into UV Coords to change the scale of a image texture?QQ截图20200609074651

1 Like

Hi @shuzhan_yang,

These are really beautiful caustics on the floor from the water surface.
To your questions:

  • Volumetric lights (god rays) and volumetric caustics are not yet possible with appleseed. For this we miss heterogeneous volumes support. We have the code for heterogeneous volumes for review but it will be for some time in the future.

  • To adjust UVs we have the asManifold2D node. You can use it to scale, translate, rotate, add offsets, adjust tiling or distort the UVs (see screenshot below)

1 Like

Thanks a lot for your reply . :grinning:

I tried tweaking all of the settings but nothing changed. Maybe it’s a bug ,I’m using blenderseed 2.0.0.

I tested it with a recent developer build and it seems to work (see screenshots, with different scales of U,V frames 0.25 and 1.0)

Which version did you tested ? Cause I find it a bit different from mine. I dont have the small arrow to unfold settings. :sweat_smile:

Here is the link to a developer version of the latest blenderseed:
https://mega.nz/file/4AJXXIJQ#6nets52a6JOmeK7SgcPhDiJmC13-0w3fneJKlPMRlN4

It has many improvements and new features e.g. support for some much used Cycles nodes, collapsible node sections, multiple OSL script nodes in a scene, improved viewport render etc.

Just note that developer versions are less tested than official and may contain bugs.

Thanks very much! :smile: I’ll have a try.

I tried the dev version but failed… :joy: The uv works fine in viewport but render couldn’t start . Perhaps I’ll continue this work later when the bugs are fixed.

I did not have problems rendering when using scaled UVs on a test scene.
That said, by using a dev version of blenderseed you likely will encounter some bugs.

It will help us when you encounter a problem that you state the error message from the console.
(In Blender under Window -> Toggle error Console) so we can get a hint if it is indeed a valid bug or just some case of usage related problem.

Many times it is the use of scenes originally made for other render engines which leads to issues.
When you take a scene for an other render engine, Cycles for instance, you have to remove all Cycles specific elements from the scene (lights and material shader graphs) and replace them with appleseed ones. My guess is that your scene is a conversion and not made from scratch for appleseed and there are some elements left from an other render engine which prevents the final render working correctly.

Anyway, thanks for posting your work in progress!

There is a mesage :
2020-06-10T19:25:20.206213Z <001> 1814 MB error | duplicate entity “fish”.
Note that when I hide the fish object , everything is fine. I think there is something wrong with its mesh data.