How to run appleseed on macOS?


#1

Hi. I just downloaded the latest 1.80 version of Appleseed for MacOS but I don’t find a way to launch the Appleseed.studio.

I get the following error.

$ ./appleseed-studio
Illegal instruction: 4


#2

Hello!

Which version of macOS? What Mac (model, year)?

Could you try to run ./appleseed.cli --system?


#3

I have MacOS 10.12.6.

$ ./appleseed.cli --system
Illegal instruction: 4


#4

Just downloaded the Appleseed 1.7.1-beta and that version it is working.


#5

Ok, that’s helpful information, thanks.

Could you tell us what Mac model and year you’re using?


#6

I have a MacMini late 2012, 2.3GHz Core i7, 16GB RAM, GTX 1060 eGPU.


#7

Thanks! We’ll make a new build and give it to you for testing.


#8

Ok. Thank you for the effort. Waiting to test again.


#9

@zohozer Hey, thanks for your patience!

Here’s a new build without SSE4.2 support:
https://github.com/appleseedhq/appleseed/releases/download/1.8.0-beta/appleseed-1.8.0-beta-0-g153757a-mac64-clang-nosse42.zip

Let’s see if this makes a difference.


#10

I’m getting the same error. I also tried the build you made without SSE4.2 support and still get the same “Illegal Instruction: 4” (also get that when I run appleseed.cli – system)

I’m running an iMac 27-inch , Late 2012
3.4 Ghz Core i7
24 GB Mem
Nvidia GeForce GTX 675MX 1 GB
Mac OS ver. 10.13.1


#11

Thanks for testing, appreciated.

The fact that a build without SSE4.2 still doesn’t work rules out the easy case.

We actually obtained a callstack from another user having the same problem and it appears that the crash occurs in one of the third-party library appleseed depends on.

We’re still investigating and we’ll report here as soon as we have a new build to try!

Sorry for the inconvenience.


#12

Just remembered today that I have a Win7 bootcamp partition on my Mini!

Just installed the Appleseed 1.8 in Windows7 and is working! The same processor with SSE4.2 under Win7 is able to run the latest Appleseed.


#13

That’s great news!

I think that clang 7.0.0 on OS X 10.10 is emitting some uncommon instructions. In fact running appleseed under a debugger (gdb or more likely lldb) would allow to pinpoint exactly what instruction is not supported by your CPU.


#14

Ok. I will test, but please can you write a short howto? I’m not a programmer, just learning some basic Python!


#15

I’ve never used lldb so you would need to consult the documentation or search on the web, however with gdb you would do something like this (from bin/):

gdb --args appleseed.studio

Then you would type

run

And finally, once it crashed with the “Illegal instruction” message, you would type

display/i $pc

to print the offending instruction.


#16

Thank you. May I test tomorrow? Today it’s Windows day for me!


#17

Anytime you wish :slight_smile:


#18

I tryed to install the gdb debugger but I get an error at signing stage:

$ codesign -s gdb_codesign /usr/local/bin/gdb
Segmentation fault: 11

Do you know a better debugger free and easy to use for MAC? Preferably with a GUI?


#19

Ok. I managed to sign the gdb without errors.

Solution here:

And here is the output:

(gdb) run
Starting program: /Applications/appleseed/bin/appleseed-studio
[New Thread 0x1403 of process 45291]
warning: unhandled dyld version (15)
Could not find platform independent libraries
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to [:<exec_prefix>]
ImportError: No module named site
[Inferior 1 (process 45291) exited with code 01]


#20

Hm. You could try lldb but it’s still a command line debugger. I don’t know of any GUI debugger for macOS.

You could also try to debug appleseed.cli instead of appleseed.studio (if it also happens to crash).

Anyway, this is all just to satisfy my curiosity. It’s not absolutely required to purse the investigation if you have better things to do… But still I think it would be interesting :slight_smile: