Max plugin features


#41

@makit3d That sounds like bugs or improper settings in appleseed / appleseed-max. appleseed should never crawl to a halt.

Would appreciate repro cases!


#42

I can’t be sure of what it is now. I saved out the objects that were causing the issue and did some test renders. Oddly the problem didn’t return but I ran into other issues, not all related to appleseed. I’ll test some more to get more results.


#43

Is there a way to blend materials in appleseed-max? Max has a blend material that I want to convert to appleseed but I don’t see a way of doing it without rebuilding the textures instead.

Haven’t had a chance to test the multi/sub-object material yet. I will probably get to it tonight while I try to figure out why the render takes so long in appleseed-max.


#44

While BSDF blending is supported in appleseed, the functionality is unfortunately not exposed yet in appleseed-max.


#45

Ran another test with my dome scene using another building design. I’m mostly testing glass settings but I just can’t seem to get the glass to pass enough light to brighten up the interior. So I have been running some tests.

In the two images attached I have the light set extremely high at an output of 40. It made only a moderate difference in the overall light level to the interior compared to setting it to 5 (usually I leave it at one and adjust camera settings using other rendering engines). These two images were mostly to test caustics. Seems the use of caustics increased the render times, as expected, but made a nice increase in light levels. The time increase wasn’t as bad as I thought it would be either.

The glass for the dome is basically a sphere cut in half. The arch. glass material you mentioned would be a useful material. I tried shelling the glass but the results were not good. Almost zero light made it through but I also didn’t try it with caustics. It would appear that caustics are necessary for a scene like this. While it may increase the render times it does get more light transported to the interior.

Image one was finished in 1hr 8min. Image two was finished in 1hr 15min. There was about a 10% increase in the times due to using other software during rendering.

Pixel Samples: 16
Tiles size: 64
Passes: 20
Bounces: 8
Max Ray Intensity: 80
…I really have no idea what to set this at but it doesn’t seem to make a discernible difference in render times but yields better images with fewer fireflies (or whatever the actual term is).
.
.
.
IMAGE ONE, CAUSTICS OFF


.
.
.
IMAGE TWO, CAUSTICS ON


#46

I ran a test today with the version provided by franz with alpha support on environment maps. In this test the glass for the dome was turned on as well as caustics. It appears the alpha support has broken caustics. In renderings created before this update this phenomenon didn’t happen.

The first image is a single sided object whereas the second is a double-sided object; essentially a sphere sliced in half and then shelled. The first image is the shelled sphere with the inner faces deleted.

You can see the dark non-transparent area in the first image and the very white area in the second (on the left). Also, I didn’t let the first image complete so there is a section of buckets left over from a previous render on the right.


#47

I missed your earlier post from Jan 16.

Regarding caustics: if the holes of the dome are made of glass, then light coming from the outside through this glass is technically a caustic. That means that none of the light coming from the outside should make it to the inside if caustics are disabled. Finally, if all the illumination is coming from the outside, and there are no holes in the structure, then the image should be completely black when caustics are disabled.

You probably want to enable caustics for this scene.

Regarding max ray intensity: technically, this sets the maximum radiance (in W.m^-2.sr^-1, i.e. watt per square meter, per steradian) that a secondary ray can carry. In practice, the idea is to find some value that kills fireflies (high intensity dots that may appear here and there) yet doesn’t reduce the global illumination contribution. The exact value of this parameter is very much scene dependent.

Regarding the renders you posted yesterday: the transparent background support should have zero impact on anything else. What’s more likely to have happened is that the development build I sent you contains unrelated half-baked changes. Could you try the following: take the appleseed.dll file from the latest official appleseed-max release, and replace the one from the build I sent you yesterday. That should ensure that the only change you now have is the transparent background support.


#48

This didn’t solve the issue. I tried recreating the glass dome thinking the geometry of the original may be the problem but this did not make any difference. I replaced the appleseed plugin files with the beta 0.4.0 files and again same problem arose. I thought perhaps it was the material with the alpha channel on the non-glass dome structure but this wasn’t it. I also turned off the environment map with no effect. I changed the sun position and the compass that is part of the sun light system. Nothing.

Now I am at a loss to understand this since this was working just a couple of days ago when I began testing asMax with the Laubwerks trees. It must be something I have changed but for the life of me I can’t figure out what it could be. So far I have accounted for any changes made and none them were to the dome other than the change in material to the non-glass object.

The scene I sent you should be exhibit the same problem. If not then it has to be something I have done to my current scene.


#49

I did more testing with multi-subobject materials. There is still the very slow process time when they are used. Aside from the problem of the number of sub-materials there is also the problem of non-square bitmaps.

WIth the above test scene I created a M/S material for the dome to separate the traingular body from the edges to be able to create a frame. There were 2 sub materials in the M/S material. When I tried to render this I had to cancel it after 45 minutes when not a single bucket was rendered.

I then broke the object up by material ID and now have two separate objects. The same materials applied produced the same result.

I tested to see if it was the material that used the non-square bitmaps. Disconnecting all but the Diffuse bitmap allowed the render to start within seconds. Attaching any one of the other bitmaps caused render times to skyrocket.

A new material was created with square bitmaps for the same object and now the renders start in seconds and run as quickly as they usually do.

It makes wonder if the size of the materials might be an issue. The non-square bitmaps were each 3763 x 5972 while the new material bitmaps were 900 x 900, a significant difference in size.


#50

Very interesting.

So if I understand correctly, you can reproduce the problem with a single simple material with a large non-square bitmap?


#51

Yes, once I changed the non-square (3763 x 5972) bitmaps to square bitmaps (900 x 900) the scene rendered very quickly.

I won’t have a chance to upload the scene now. I am in the middle of moving and won’t have my ISP connection installed for a few days. I may be offline for about a week. Once I am back the scene will be posted.


#52

I just realized that I should have asked this question earlier:

What file format are your textures in, and are they tiled?


#53

I’ll have to look at it later but I believe the images were all .jpg format and no, not tile. That feature isn’t supported yet, unless it was added with a recent build and I didn’t know it.


#54

That’s probably the reason then, appleseed doesn’t cope well with non-tiled textures at the moment. I would recommend converting your textures to tiled OpenEXR files, if you can.


#55

I must not understand what you mean by ‘tiled’. Would you describe this to me?


#56

“Tiled” means that the texture is internally represented by a 2D array of individual tiles, instead of a 1D array of horizontal lines.

Tiled texture format are efficient because appleseed may decide to read only some tiles that it needs, instead of the entire file.

There is a number of texture formats that supports tiling, the most notable one being OpenEXR.

Most renderers, like V-Ray, cope well with non-tiled textures, but currently appleseed doesn’t.


#57

Material balls and default shader display black color. What should i do ?

Please how can i convert my vray and mental ray materials to appleseed materials ?


#58

I tried rendering a lit scene with mr sky portal in appleseed and i saw this error

"An exception occurred while rendering with 3ds Max.

This render will abort. If you render again without resolving the exception, you may experience instability.

Unknown Exception" What is the problem ?


#59

Mental Ray and appleseed are two different render engines.


#60

“An exception occurred while rendering with 3ds Max.”
This comes because mr sky system is not compatible with appleseed which has it’s own sky environment.

In general materials and shader are not common or exchangeable between different render engines, there is no universally accepted standard yet. Commercial render engines have sometimes a conversion tool available but in general you cannot simply load a mr scene and switch to say vray or appleseed without adapting the materials to render correctly.