Maya installation problem


#1

Hello everybody,
Need a little help please.
Spent half a day trying to install appleseed for Maya. Somehow I cannot succeeded to get maya load the appleseed-maya.mod file. I’m doing exactly how it is described in appleseed-maya installation doc. I tried by adding MAYA_MODULE_PATH to maya.env file and to add system environment variables but maya not seeing appleseed plugin in anyway. Then I decide to try add all paths manually and added to maya.env following:
APPLESEED_COREDATAPATH = C:\ProgramData\appleseed
APPLESEED_PLUG_IN_PATH = %APPLESEED_COREDATAPATH%\plug-ins\2017
APPLESEED_SEARCHPATH = %APPLESEED_COREDATAPATH%\shaders
APPLESEED_SCRIPT_PATH = %APPLESEED_COREDATAPATH%\scripts
APPLESEED_RENDER_DESC_PATH = %APPLESEED_COREDATAPATH%\renderDesc
APPLESEED_XBMLANGPATH = %APPLESEED_COREDATAPATH%\icons%B
APPLESEED_CUSTOM_TEMPLATE_PATH = %APPLESEED_COREDATAPATH%\scripts\appleseedMaya\AETemplates
APPLESEED_SHELF_PATH = %APPLESEED_COREDATAPATH%\prefs\shelves
APPLESEED_PRESET_PATH = %APPLESEED_COREDATAPATH%\presets
MAYA_PLUG_IN_PATH = %APPLESEED_PLUG_IN_PATH%
PYTHONPATH = %APPLESEED_SCRIPT_PATH%
XBMLANGPATH = %APPLESEED_XBMLANGPATH%
MAYA_RENDER_DESC_PATH = %APPLESEED_RENDER_DESC_PATH%
MAYA_CUSTOM_TEMPLATE_PATH = %APPLESEED_CUSTOM_TEMPLATE_PATH%
PATH = %APPLESEED_COREDATAPATH%\bin
MAYA_PRESET_PATH = %APPLESEED_PRESET_PATH%
MAYA_SHELF_PATH = %APPLESEED_SHELF_PATH%

Everything according to my appleseed folder path and what is in appleseed-maya.mod file. So after that I can see appleseedmaya plugin but Maya gives me this error when I’m trying to load it:
// Error: file: C:/Program Files/Autodesk/Maya2018/scripts/others/pluginWin.mel line 290: Unable to dynamically load : C:/ProgramData/appleseed/plug-ins/2017/appleseedMaya.mll
The specified procedure could not be found.
//
// Error: file: C:/Program Files/Autodesk/Maya2018/scripts/others/pluginWin.mel line 290: The specified procedure could not be found.
(appleseedMaya) //

Which indicates that I’m doing something wrong. Checked 100 times but cannot find mistakes in maya variables.
Anyway if someone could help me with installation I will really appreciated since I’m out of ideas on that…
Thanks.


#2

Hi @shrisha,
from your error message it seems you use Maya 2018. The appleseed plugin is compiled for Maya 2017 and that is probably why you get an error message. If you open the appleseed-maya.mod file with a text editor you will see that in the first line it is written something like:

  • MAYAVERSION:2017 PLATFORM:win64 appleseed-maya 1.1.0-beta .
    You may change it to: + MAYAVERSION:2018 but I doubt the plugin (appleseedMaya.mll) will load correctly in Maya 2018 as it is compiled against the Maya 2017 SDK.

#3

Thank you Mango for your reply.
Yes, I tried edited this too and changed folder name accordingly . no effect. May be you right it is only for 2017. On download page written: This is a beta release of appleseed-maya, an appleseed plugin for Autodesk Maya 2017 and later. So I presumed that it will work on 2018 too.


#4

Hi @shrisha,

Sorry, the “and later” phrase is a bit confusing. The plugin is known to compile and work with Maya 2018 but the the binaries we release are for Maya 2017 only.

Maybe you can try to compile the plugin yourself? It shouldn’t be very hard.
Or if you have access to Linux, we can probably upload a Maya 2018 build.

Est.


#5

Thank you Est. Now it’s making sense :slight_smile: Yes I use linux will try there today. Never compile anything for windows, if someone could give me the link to some tutors then I probably will manage :slight_smile:


#6

@shrisha
I made a Maya 2018 build for Windows of the latest git-master. It should run on any reasonably new processor (Haswell generation and newer).
Note, this is not an official build from appleseedhq and shouldn’t be considered as that.
appleseed-maya2018-1.1.0-beta-win64.zip (19.3 MB)

Enjoy!


#7

Yay! Thank you so very much! :))))


#8

It’s working!!! :slight_smile:


#9

Thank you so much Mango3. Works perfectly. And I really like it, from very first time to check it out 20 minutes is enough to figure out what is what. Workflow is simple and settings is sufficient enough to get great result. Material presets are awesome.


#10

Thanks @shrisha for the nice words and @Mango3 for the binary.

We are lacking some user testing of the Maya plugin. It is the least used of our plugins so far.

@shrisha if you would be interested in doing some testing, opening tickets for things that don’t work and sharing ideas that would be great.

Thanks!

Est.


#11

I would love to! Only cannot promise full dedication since I have a job and I will able to do this only in my free time . But definitely I’m eager to help.
Thank you! :slight_smile:


#12

No worries, same problem for all of us :slight_smile:


#13

All right, I have few thing to say :slight_smile: , where should I go making some notes and suggestions ? Or just continue on this thread?


#14

Hi @shrisha,
I think the forum is perfectly fine for suggestions and feedback. It gives others an opportunity to chime in (This is my personal opinion)

Two suggestions:

  • This thread is under the Help section about Maya installation problems. It would be more helpful for others to open a new thread with a matching title if you want to discuss workflow issues or have feature suggestions.
  • In case you find a bug which is not yet in the list of issues report it in https://github.com/appleseedhq/appleseed-maya/issues

#15

sure.


#16

Hi Mango3,
I’m using your build but still getting the same error message Shrisha was getting (DLL) initialization routine failed. I’d greatly appreciate any advice.


#17

Hi @LoneCrayon,
The issue @shrisha was unable to load the plugin initially was because the official build was compiled for Maya 2017 and he uses Maya 2018.
Unfortunately, the Maya plugin has to be compiled for each version of Maya specifically, it cannot be used for any other version.

  1. If you have Maya 2017 for Windows or Linux then install the official appleseedhq build from here: https://github.com/appleseedhq/appleseed-maya/releases
  2. If you have Maya 2018 for Windows, then use the one posted above.

#18

hi @Mango3,
Thanks for your reply.
I had used the 2018 build but still getting the same error. Sometimes I miss very obvious stuff though :frowning:
The appleseedMaya.mll shows in the Plug-in-Manager so I think everything’s pointing in the right direction. I have Maya 2018 running on windows 10Pro.
Is there anything else I should be checking?


#19

The Maya build I made is compiled with AVX2 instructions support. That means that you will need at least a Haswell generation (4th generation Intel Core) or newer processor that support these instructions. If your processor does not support AVX2 then it won’t work, even if you have Maya 2018.
In that case I can make a new build with AVX2 disabled.


#20

Ah, unfortunately my processor is only AVX (Intel Xeon E5-2630 v2, unfortunately).
That would be amazing if you could do a new build. I look forward to trying it out