appleseed Users Forum

Problem with assigning materials


hello everyone, i have a problem when i render a head model in appleseed.
when i convert the model from obj to binarymesh, the program crashed and i have to use the obj model.
but after load the obj model, i can not assign material to it. i have tried many method.
1.create disney material and assign to the front side, it appears red as if no material assigned to it
2.create disney material and assign to the back side, no influence
3.create disney material and assign to both sides, the head mesh disappears!!!
4.create generatic material and other mateiriasl, do not work
5.add different lights, do not work

no matter what i do, the result is all the same: the material can not apply to the head mesh. and you can see that other objects seems works(like cube and sphere)
what is the problem for this mesh(this mesh is the head model by blender in appleseed website)

19-7-22: maybe I solved the problem. i build a new scene to debug this, and maybe this is the problem of “EDF”. First, I build a new scene like the following:


The material is physical surface shader and Lambertian BRDF. the important part is the light material, which bind a EDF
:image
when i set the edf “Importance Multiplier” or remove the bind , the scene will be all black or all red if no materials assigned to it:
will be black if wall material assigned to it:

will be all red if no material assigned to it:

all in all, there must be" light and sutiable bsdf" to make a scene render correctly if you use physical light simulation.

Hi @shengfu_zhai,

welcome to our forum!
Can you please state what application-plugin you use. From your description it seems you try with appleseed.studio to assign materials. I would advise for scene building to use a 3d-application (Blender, Max, Maya) with our plugins. appleseed.studio is mainly a tool for scene inspection and debugging and not suited to build or extensively modify them.

Assigning materials to objects is similar to other render engines within the respective 3d-applications.

have solved,i changed to another scene and it worked.I will see why this happens and tell you the reason

I used this blender model


I load the model in another scene and now it can work. but i still do not know the reason. i will see the detail of different scene. the following is my render :smile:

still, lots of adjusments are needed to get a better result

Well I used an HDRI for lighting, an as_StandardSurface for the skin, also random walk SSS :smiley: and finally some post production and color correction

oh thank your very much for your detailed description。 I will use your description to build the scene, and hope i can produce similar result as yours。 :smile:

2 Likes