Problem with Blender after installing Blenderseed and appleseed


#1

I installed Appleseed and the Blenderseed add-on in Blender 2.79 on my Macbook Pro
Blender 2.79 has since refused to start, I just get the dock icon bouncing up and down. If I hit command-option-escape I get Blender (not responding)
I’ve installed a new copy from the original .zip file I had already downloaded, Downloaded a new .zip and installed from there and have copied 2.79 which is working on my Mac Pro to my laptop but none of these attempts has made any difference.
I can’t get 2.79 to run. 2.80 works, as does 2.78
Anyone have any ideas - both my computers are running OS 10.10.5


#2

Hi, what happens if you try to run appleseed.studio (the file is called appleseed-studio on macOS) that you can find in the bin/ directory of your appleseed installation? I suspect that your Mac is too old and doesn’t support the SSE4.2 instruction set, which is required by appleseed.


#3

You can uninstall blenderseed by deleting the blenderseed folder from blender-addons/addons/ (I don’t know where these are located on macOS but you should be able to locate them easily.)


#4

Thanks for the input. I’ve tried new copies of Blender 2.79 which don’t have the Blenderseed add-on installed and they will not run. 2.80 works, as does 2.76, but no go with 2.78 or 2.79.
I think I’ve removed all of Appleseed from my laptop, unless there are hidden files that I don’t know about.
I have a bunch of stuff on the go using the principled shader so 2.76 is no help and I’m not up to speed on 2.80.
Any further info would be very much appreciated.


#5

Hi @signguy,
It may be related to the specific python version Blender uses. Blender 2.8 uses python 3.6, Blender 2.78 and 2.79 use python 3.5, and Blender 2.76 uses python 3.4. Maybe your python 3.5 installation got mangled. This would explain your behavior. I don’t have a Mac so I cannot give more help but it may be worth to check out.


#6

Thanks for the input.
I installed Python 3.5 and downloaded a fresh .zip of 2.79.
Still no go.
Very frustrating.


#7

One other thing comes to mind which you may have done already.
Blender stores configuration data in 3 different directories (see image). Have you tried to remove all previous instances of blenderseed in the 3 directories and then reinstalled a current one?