appleseed Users Forum

Simple metal material test - Image texture issues - Solved


#1

Just a simple metallic ball. Nothing much, just playing around and blending shaders. Funny thing, that sometimes I can’t load image textures even if they are png-s. Some textures work some not. Dunno why. For example there is a set let’s say three textures for a wooden floor: diffuse, bump, reflection. The diffuse loads well. The blending amunt should be set by the reflection, sometimes it doesn’t load. Bump is the same. Out of luck. Don’t know the reason of this. Haven’t tried to load directly into appleseed studio though, just in blender with mat preview. Anyway metal material test:


#2

Can you provide a test scene to repro the texture loading problem?


#3

Again this problem was my fault, and again was solved by Franz. So you have to set the color space of the majority of the textures you use for defining bump, normal, blend value to ‘linear’ instead of ‘sRGB’. That’s all. So it’s not a bug in appleseed but in me, that I don’t check the Log for error messages. :slight_smile:


#4

Any new image with all of this fixed? :wink: