[Solved] Error while loading shared libraries: libboost_chrono-gcc


#1

Hi, i just downloaded and unpacked appleseed into my /opt/appleseed folder. It ran fine when i first tried to start it in the download folder. But as soon as i copied it to the /opt/appleseed folder it gives me this message:

“./appleseed.studio: error while loading shared libraries: libboost_chrono-gcc48-mt-1_55.so.1.55.0: cannot open shared object file: No such file or directory”

I’m not very versed in linux, so i have a hard time finding out how to make appleseed find those libraries, even though i know they are located in /opt/appleseed/lib
Would it be possible to get a little help to get the correct command from someone in here? :slight_smile:

I also need to put the bin folder in the path, so gaffer can find it…

Any help would be very much appreciated.

And, thank you for creating appleseed. :slight_smile: It’s a very nice renderer. (hoping for an official blender addon soon. :slight_smile: )


#2

Forgot to say i’m running Antergos 64bit system… :slight_smile:


#3

Hi,

Pinging @est, he’s the Linux master here.

We’re about to release the next version of appleseed (1.8.0-beta) and there is a Blender plugin!


#4

Ah, okay, cool. :slight_smile: how long till the 1.8 version comes?


#5

It’s a matter of days. We’re preparing the release as we speak. Hopefully before Friday this week.


#6

nice… :slight_smile: I’ll wait till then… I’m probably stepping a bit overboard here, but it would be nice if it could be added to the AUR repository for arch-linux or the normal repository… :smiley: (no pressure. lol)


#7

It would be nice indeed! We would love people to step in and build/maintain packages for the various Linux distros. We’re unlikely to take care of this ourselves as we don’t have the developer bandwidth.


#8

Yeah… unfortunately, I also suffer with the ‘manpower/time/knowledge’ aspect to do those things…


#9

Hi,

I tried quickly here and I could not reproduce it.

If you have the chrpath util you can run “chrpath /opt/appleseed/bin/appleseed.studio”.
It should print this:

RPATH=$ORIGIN/…/lib

If that matches, then check that /opt/appleseed/lib has libboost_chrono-gcc48-mt-1_55.so.1.55.0.

Est.


#10

Thanks for the quick replies guys. :slight_smile: Very much appreciated.
This is what i got:

[[email protected] ~]$ chrpath /opt/bin/appleseed.studio

open: No such file or directory
elf_open: No such file or directory

What do i do to make it appear like yours?

Edit: It does have the libs in the right folder… I think I’m just having a hard time with the commands for making things available in the path… Tried the export PATH to the /opt/appleseed/bin folder, but that disappears everytime i restart the terminal window… In addition it doesn’t really help appleseed find the libs either… forgot to say this, that’s why i edited…


#11

Are you sure /opt/bin/appleseed.studio is the right path?


#12

Ah, actually wrote the wrong path, how did i not notice that…?

[[email protected] bin]$ chrpath /opt/appleseed/bin/appleseed.studio
/opt/appleseed/bin/appleseed.studio: RPATH=$ORIGIN/…/lib
[[email protected] bin]$

That’s how it should look…

Edit: The libs are also listed where that is, so it’s weird that it can’t find it.


#13

Quick question: what permissions do appleseed files have? What owner/group?


#14

This is what i get when i ls -l my opt folder.
drwxrwxr-x 16 cet root 4096 Nov 22 10:06 appleseed

But all the files inside seems to be root… ups… linux newbie error maybe… :stuck_out_tongue:


#15

oy… something that simple… okay, now i’m actually embarrassed… :blush:
Thank you for pointing out the obvious…


#16

You’re welcome, glad that we could sort it out!


#17

:slight_smile: Btw… probably not the right thread, but does anyone have experience with the latest gaffer and appleseed 1.8? Right now my gaffer won’t even start the appleseed that is in the same package. Gaffer starts, but it seems that there is some stuff going haywire with appleseed at startup. Something about libcurses.so.5 import error.

Maybe i should start another thread?


Gaffer and appleseed 1.8.0